Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/tetrac2/public_html/smf_forum/Sources/Load.php(225) : runtime-created function on line 3
Recent Posts
TETRA - Tech Teams for Resourceful Applications
December 16, 2017, 01:16:50 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: SMF - Just Installed!
 
   Home   Help Search Login Register  
Pages: [1]
 1 
 on: February 19, 2011, 05:59:54 PM 
Started by glforbes - Last post by glforbes
Recently I have tried to compile Apache-Ofbiz-10.04 using Ubuntu Linux. To do this you need a Java SDK and not JRE version. Well this took many attempts to install the JDK from Sun and not the OpenJRE from the standard Ubuntu repository. I did a lot of Googling about how to do this because I had a lot to learn. Like:
  • How to setup a new script to install
  • How to set the default Java version
  • How to use "update-java-alternatives" command
  • How to configure a new Java SDK for "update-java-alternatives" command to work
  • A list of all my mistakes

     I followed the post at http://codeslinger.posterous.com/how-to-install-java-7-on-ubuntu

     The site contains a shell script to register all the executable binaries. There is a button to download this script, but it did not work. I just copied and past the listing to an editor (gedit). Then saved it to my home documents directory.

     I opened a terminal and executed the shell command. This error shows up on the terminal - Syntax Error: word unexpected ( expected  "do"). But the "do" is there and everything looks correct. I remove all the blank lines in the script but I still get the error. After much time Googling and not finding an answer, I finally resort to my tried and true method of problem solving. Divide and Conquer.  I copy and paste the first few lines to a new file in gedit. Save as different name and execute. Ouch! It works. I copy more and try. It works. I copy all from original fill to new and it works. Mmm! I'm thinking, then the light comes on and I put all the peaces together.

     The answer is that when I copy and paste the first edit it came from an HTML page. Html uses the standard carriage return - line feed. This goes way back to the Teletype days. Linux uses the character - new line. The unexpected word in the above error was carriage return - line feed. So the copy and paste from one edit to another fixed my problem. Now I know how life is not easy and how you can be trick by what you can't see. But my divide and conquer saved me. (The scientific name for this is called "Binary Search").

 2 
 on: November 22, 2010, 08:53:20 PM 
Started by glforbes - Last post by glforbes
In the past two weeks I have been wrestling with the so called "Google Redirect Virus'. Yes you can Google this phrase and find many blogs of people in the same situation. All these blogs talk about how to remove this in Windows. But I am Linux guy. How did this thing get in my Ubuntu Linux?

Well! I do think the whole thing started with me. I do have computers here that are running Windows and are on the Internet. I just recently installed an anti-virus software and scanned the system. It found 255 cookies related to web browsing.

What does this virus or malware look like? if you search on your website, cast-cebu.org, then click on the link, you get redirected to a completely different site. The mouseover link shows a very long URL with many parameters. Other sites have a direct URL to the site. I search for many days on this Google redirect thing and find no solution that makes sence. They all say the problem is on my computer. Lets look at the evidence.

1. Different search engines show the same behavior.
2. Different browsers show the same behavior.
3. Different computers show the same behavior.
4. Different sites show Different behavior. For me, my site is infected, others are not.

The problem has nothing to do with Google. This is not the Google Redirect Virus. All the other search engines exhibit the same behavior. Nothing to do with my computer or browser. So the problem must be else ware. Maybe my website host, a dns server, my website or my local router.

I do have a dhcp(Dynamic Host Configuration Program) server and DNS(Dynamic Name Server) router installed on my Linux box. I need this because I host a local Dynamic IP website. URL http://tetra-wonderland.dlinkddns.com I use this to communicate to my customers and try out new programs I write. Anyway I checked this all out looking for recent changes via a changed date codes on the files. Found nothing. My connection to the Internet is via a cable modem. The modem has no configurations to set. I strike out there. Going further back in the chain, I change the my DNS default Internet name server. The problem is still there. Only one more thing to check, my site. But what could be the malware on my site and how would it get there?

I now go back to Google and search on 'hosted website malware'. I run into a post that explains a malware that is encoded into all php files. This is code at the beginning of each <?php tag. It looks something like this 'eval(base64_decode'(Google this phrase). It is then followed by a long list of characters that make on sense. Yes! I found the code string in all my site PHP files. Now I download the complete website. I manuals edit each PHP file with Bluefish and removed the malicius code. That fixed the problem, but is it the final cure? How do I know that I got all files clean.

Today I Google more about removing the eval malware and find web site you can pay to remove malware. Sites with Linux code to auto remove the code string and sites to check if you are infected. I now think I have learned enough that I am smarter than the bad guys that infected my site. Mmmm! Can I reserve my judgment on that statement. I may want to change it later. I still need to know is how the perpetrators got into my website?

Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!